Bug #830

avatar

Crashes on opensuse 12.3

Added by Brandon Watkins 4023 days ago. Updated 2980 days ago.

Status:Rejected Start:04/16/2013
Priority:High Due date:
Assigned to:- % Done:

0%

Category:-
Target version:-
Complexity:

Found in Version:

0.8.10

Votes: 0

Description

Installing smuxi on a clean (but fully updated) install of opensuse 12.3 results in an immediate crash every time I try to open smuxi. the GUI just never opens. If I open it via the terminal I see these errors:

Missing method System.Reflection.Assembly::op_Equality(Assembly,Assembly) in
assembly /usr/lib/mono/2.0/mscorlib.dll, referenced in assembly
/usr/lib/mono/gac/log4net/1.2.10.0__200a2bd1219e83a8/log4net.dll

Unhandled Exception:
System.TypeInitializationException: An exception was thrown by the type
initializer for Smuxi.Frontend.Gnome.MainClass --->
System.MissingMethodException: Method not found:
'System.Reflection.Assembly.op_Equality'.
at log4net.LogManager.GetLogger (System.Reflection.Assembly
repositoryAssembly, System.String name) [0x00000] in <filename unknown>:0
at log4net.LogManager.GetLogger (System.Type type) [0x00000] in <filename
unknown>:0
at Smuxi.Frontend.Gnome.MainClass..cctor () [0x00000] in
/home/abuild/rpmbuild/BUILD/smuxi-0.8.10.1/src/Frontend-GNOME/Main.cs:36
--- End of inner exception stack trace ---
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An
exception was thrown by the type initializer for Smuxi.Frontend.Gnome.MainClass
---> System.MissingMethodException: Method not found:
'System.Reflection.Assembly.op_Equality'.
at log4net.LogManager.GetLogger (System.Reflection.Assembly
repositoryAssembly, System.String name) [0x00000] in <filename unknown>:0
at log4net.LogManager.GetLogger (System.Type type) [0x00000] in <filename
unknown>:0
at Smuxi.Frontend.Gnome.MainClass..cctor () [0x00000] in
/home/abuild/rpmbuild/BUILD/smuxi-0.8.10.1/src/Frontend-GNOME/Main.cs:36
--- End of inner exception stack trace ---

History

Updated by Kai Korla 4010 days ago

avatar

This is because mono not using the correct runtime. You can fix this to add the following lines into the <configuration> Section in the files

/usr/lib/smuxi/smuxi-server.exe.config
/usr/lib/smuxi/smuxi-frontend-gnome.exe.config

<startup>
<supportedRuntime version="v4.0.30319" />
</startup>

regards
Kai

Updated by Kai Korla 4010 days ago

avatar

-<startup>
<supportedRuntime version="v4.0.30319" />
</startup>-

Please use

<startup>
<supportedRuntime version="v4.0" />
</startup>

regards
Kai

Updated by Mirco Bauer 3955 days ago

avatar

I hope the packages will be fixed by passing MCS=/usr/bin/dmcs to ./configure, else it will use the default compiler which is /usr/bin/gmcs. Do you know if opensuse has a bug report about this already? Because in Smuxi I can't fix this...

Updated by Mirco Bauer 2980 days ago

avatar
  • Status changed from New to Rejected

This is not a bug in Smuxi

Also available in: Atom PDF