Feature #63

avatar

replace GNOME# API calls with GTK# API

Added by Mirco Bauer 5846 days ago. Updated 5466 days ago.

Status:Closed Start:
Priority:Immediate Due date:
Assigned to:avatarMirco Bauer % Done:

100%

Category:Frontend GNOME
Target version:0.6.4
Complexity:

Votes: 0

Description

Currently smuxi uses GNOME# just for the Druid-API (assistant/wizard). Since GTK+ 2.8 (I think) that can be replaced with a GTK+ API. This blocks the support of Mac OSX support!


Related issues

blocks Smuxi - Bug #129 configuration error dialog [win32] Closed

Associated revisions

Revision 4254d68738ec302c043e46c0e2587775dc03ff63
Added by Mirco Bauer 5466 days ago

Merge branch 'feature/#63_drop_gnome-sharp' (closes: #63)

Conflicts:
src/Frontend-GNOME/Frontend-GNOME.mdp
src/Frontend-GNOME/gtk-gui/gui.stetic

History

Updated by Mirco Bauer 5657 days ago

avatar

This also blocks decent Windows support. gconfd and annoying gnome-sharp + libgnome libraries have to be bundled as they are not part of the official GTK# installer anymore :(

Updated by Mirco Bauer 5538 days ago

avatar
  • Target version changed from 0.8 to 0.6.4

Updated by Mirco Bauer 5531 days ago

avatar
  • % Done changed from 0 to 30

Updated by Mirco Bauer 5466 days ago

avatar
  • Status changed from New to Closed
  • % Done changed from 30 to 100

Also available in: Atom PDF